
Chapter 7 - Printing Other Items

73

Chapter 7

Printing Other Items
Printing on General Items

The T-Jet Jumbo 2TM can print on almost any fabric or material and usuallyyou don’t 
even need a clamping device. FastINK for your T-Jet Jumbo 2TM is a water-based
textile ink designed to work not only on natural fabric materials, but also on non-textile
items such as unfinished wood, mouse pads, golf balls, keyboards, light switch covers
and much more. With the help of Fast T-Jet Non-Textile Series Pre/Post Treatment
FastINK will adhere to almost any type of surface.

If you’re printing on smaller items such as hats, golf balls
or mouse pads, these can be placed on smaller Garment
Holders available as accessories for your T-Jet Jumbo
2TM or you can make your own. Spray adhesive or sticky
Table Tack can be placed on these special holders to
keep the items from moving. Just remember to ALWAYS
check the print head clearance.
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Location and Placement
The hardest part of printing on odd size items is determining their print location.
Remember, if you are facing your T-Jet Jumbo 2TM, the outer right edge is “zero” in 
your graphics program. You can simply make a Template or Custom Page Size to
match the size of your shirt holder.

FastARTISTTM allows you to adjust the page size to match your items in the Page Setup
window. You must also set the correct page size in FastRIP Setup.

 FastARTISTTM Page Size–Go to Layout > Page Size
 FastRIPTM Setup–Go to File > FastRIP Setup
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Adjusting the Bed Height
When printing on non-textiles that require a special holder, you may need to purchase
the Non-Textile Height Adjustment Board in order to raise the specialty holder closer to
the print head. For the best prints, the printing surface should set to 1/8inch (3mm)
below the printing head. If the item has a seam or excess fabric, these areas should be
lower than the main printing surface.

Important Note: Make sure that the garment or non-textile item does not sit closer to
the print head than the preferred of 1/8inch (3mm).

Use Spray Glue, Table Tack or Double-Sided Tape To Hold Items in
Place
It may be necessary to design a special cutout from foam or other thin material that is
the same size as the printing area. You can simply spray glue this to your normal
Garment Holder or use spreadable Table Tack (available from US Screen) to hold the
item in place. Table Tack stays sticky for dozens, and even hundreds of prints, and it
can be “renewed” by simply wiping it down with a wet rag.

Special double-sided tape available is also available from US Screen for this purpose.

Printing Baseball Caps

It’seasy to apply graphics to baseball caps, both with and without seams. When using
the optional Baseball Cap Holder, pull the sweatband out of the way, push the cap
against the spring guides and use your finger to press the point in the crown down
around the point on the cap holder. Stuff the excess cap under the holder, lower the
clamp and make a print.It’s worth noting, some caps will require a little more practice to
load than others.

Always be sure to check and double check for head clearance. This will minimize print
head replacement as well as ensure better images.
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Since a cap may not fit in a conveyor dryer or heat press for ink curing, a simple hair
dryer or industrial heat gun is all you need to cure the final print. You can also simply
remove the holder with the cap in place and lay it under a standard heat transfer press.
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NON-TEXTILE PRINTING
Required Items

You should have the following in order to print on Non-Textiles.

1. Non-Textile Pretreatment
2. Non-Textile Post-Treatment
3. Fine Bristle Brush

Optional materials may be required.

1. Non-Textile Primer Treatment
2. Holder for object (i.e. Golf Ball Holder)
3. Non-Textile Height Adjustment Board
4. Non-Textile Print Modes (Located on CD or online @

http://screenprinters.net/non-textile_home.php?)

CAUTION: WEAR GLOVES WHEN APPLYING ANY PRIMER OR PRE/POST
TREATMENT. USE WITH ADEQUATE VENTILATION. HANDLE WITH CARE AND
PROTECT EYES WITH SAFETY GLASSES. BEFORE USING ANY PRODUCT,
CONSULT THE MATERIAL DATA SAFETY SHEET (MSDS) THAT IS INCLUDED
WITH THE PRODUCT OR AT WWW.SCREENPRINTERS.NET

KEEP OUT OF REACH OF CHILDREN

Getting Started

Before printing, it will be necessary to determine if the surface intended for printing will
allow the pretreatment to stick. Certain surfaces will allow you to apply the Non-Textile
Pretreatment directly while others will require an application of Non-Textile Primer
Treatment first. Generally, smooth surfaces such as light switches, keyboards and gloss
tiles will require an application of Non-Textile Primer Treatment before the Non-Textile
Pretreatment.

To Test: Apply a very small amount of Non-Textile Pretreatment to the intended printing
surface. If the pretreatment does not sick to the surface but instead runs off, then it will
be necessary to use the Non-Textile Primer Treatment.

Important Note: If this is your first time using the Non-Textile Pretreatment, it is
recommended pre-treating small quantities in the beginning to familiarize yourself with
the process.
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Fast T-Jet™ Non-Textile Primer Treatment

Fast T-Jet™ Non-Textile Primer is designed to be used on high gloss
non-porous surfaces as a primer coat prior to the application of our
standard Fast T-Jet™ Brand Non-Textile Pretreatment.

This Primer is designed as an undercoat for our Fast T-Jet™ Brand Non-
Textile Pretreatment. DO NOT print directly onto this product.

DIRECTIONS: Dip a fine bristle brush in the Primer, wiping
off any excess on the side of the bottle. Gently brush Primer
over the surface of the item, making sure there are no
uneven areas. Please note that it is very important that the
Primer be applied in a thin even layer to ensure best print
quality.

FOR BEST RESULTS: Apply this product with a fine paint brush. After application is
complete, clean brush thoroughly with hot water to remove all Primer Treatment.

This product can be sprayed on, but the application may not be as smooth as necessary
for good print reproduction. If applying with an airbrush, spray bottle or paint sprayer
you may need to dilute solution slightly with water. Apply in smooth, thin, even layers.
Two coats may be necessary.

Clean brushes with soap and water immediately after use.

Allow primer to thoroughly dry before applying the Non-Textile Pretreatment. Dry time
will vary but can take up to one hour or more. To speed up the drying process use a hair
dryer, heat lamp, or heat gun set on a low temperature setting. Protect work surface
with newspaper.

A heat press can also be used by setting the non-textile item under the press heating
element. However, be careful not to allow the heating element touch the item.

Fast T-Jet™ Non-Textile Pretreatment

Fast T-Jet™ Non-Textile Pretreatment is designed for use as an inkjet ink
receptive base coat when printing directly onto non-textile materials such
as plastic, metal, and wood using your standard T-Jet Jumbo 2TM

Garment Printer and FastINK2™ Textile ink. For increased durability of 
the final print, use our Fast T-Jet™ Post-Treatment on top of the final
print. Certain high gloss material may need to be prepared with our Non-
Textile Primer Treatment BEFORE using the pretreatment. You do NOT
need to change inks when using this product.
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DIRECTIONS: If working on smooth, glossy surfaces where good adhesion is
important, apply the Fast T-Jet™ Non-Textile PRIMER before using this product. Primer
Treatment must be thoroughly dry before applying this pretreatment.

Dip the fine bristle brush in the pretreatment wiping off any
excess on the side of the bottle. Gently brush pretreatment
over the surface of the item, making sure there are no
uneven areas. If Primer was applied, then the Primer treated
surface must be covered with pretreatment. Please note that
it is very important that the pretreatment be applied in a thin
even layer to ensure best print quality.

FOR BEST RESULTS: Apply this product with a fine paint brush. After application is
complete, clean brush thoroughly with hot water to remove all pretreatment.

This product can be sprayed on but the application may not be as smooth as necessary
for good print reproduction. If applying with an airbrush, spray bottle or paint sprayer
you may need to dilute solution slightly with water. Apply in smooth, thin, even layers.
Two coats may be necessary.

Clean up brushes with soap and water immediately after use.

Allow pretreatment to thoroughly dry before printing on it. Dry time will vary but can take
up to one hour or more. To speed up the drying process use a hair dryer, heat lamp, or
heat gun set on a low temperature setting. Protect work surface with newspaper.

A heat press can also be used by simply setting the non-textile item under the press
heating element. Be careful not to let the heating element touch the item.
Since the pretreatment process can take some time to dry, it is recommended that you
pre-treat as much of the production run as possible to avoid delays due to drying time
(Do this only after becoming proficient with the Non-Textile Primer/Pretreatment).

Setting up an Image for Print
To set up an image for print, you must use a graphics application such as
FastARTISTTM, Photoshop or CorelDraw. Anyone of the three applications is capable of
printing to FastRIPTM, but for this manual we are going to set up the image using
FastARTISTTM. The steps in the other graphic applications will be very similar. Please
consult your applications owner’s manual if needed.
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1. Set up the printing area in which you will be printing. To do this
you will need a measuring tape to measure the width and height
of the Non-Textile item. In FastARTISTTM select File>FastRIP
Setup.

2. From the Setup window, select Page
Setup Tab. In the Page Setup tab, select
Custom under the page option. Enter the
height/width of the Non-textile item you
measured. When you are done entering in
the values, click OK to return to the
workspace.

3. Select Layout>Page Size. In the Page Size
window, enter the height/width of the Non-textile
item you measured. When you are done entering
in the values, click OK to return to the workspace.
The non-textile item dimensions are now
represented by a black box located within the
workspace. If this is not displayed, click View >
Show Page Size to view black box.
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4. Import the image you intend to print, positioning it where you like it on the item.
For further FastARTISTTM help, please reference the user manual.

5. Once you are done setting up in FastARTISTTM, Photoshop or CorelDraw, you
will need to print to FastRIPTM.

Printing to FastRIPTM - FastARTISTTM Click File > Print to FastRIP.
Position the image, then click the printer icon located in the printer tool box
to complete sending the image to FastRIPTM.

Printing to FastRIPTM - Adobe Photoshop

Go to the File menu and select Print with Preview. Click Page Setup. Click
Printer. In the Page Setup menu select the Fast T-Jet Jumbo 2TM printer.
Click Properties. Click Advanced. Set the Page Size. Go the Printer
Features section. Bring the Print Mode menu down to select the Color
Print Mode. Bring the Underbase Mode menu down to select the
Underbase Print Mode. Set the number of ink passes for underbase and
color. Click OK in Advanced Options. In Document Properties set to
Landscape or Portrait for orientation. Click OK. Click Print.

Printing to FastRIPTM–CorelDraw

Go to File> Print. On the General tab
select the Fast T-Jet Jumbo 2TM printer.
Click Properties. Click Advanced. Set the
Page Size. Go the Printer Features
section. Bring the Print Mode menu down
to select the Color Print Mode. Bring the
Underbase Mode menu down to select
the Underbase Print Mode. Set the
number of ink passes for underbase and color. Click OK in Advanced
Options. In Document Properties set to Landscape or Portrait for
orientation. Click OK. Click Print.

Important Note: When printing on a non-textile item on the garment holder,
make sure a place a piece of paper over the rubber pad to protect it from ink.

Printing Multiple Items on the Print Bed
When printing multiple items on the print bed at the same time you must configure the
FastARTISTTM or graphics application so that each individual image is applied in the
proper location.
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1. The total print area must first be calculated. Measure the length and height of all
the items combined as they will be printed.

2. From the FastRIPTM Setup window, select the Page
Setup tab. Select Custom under the Page option.
Now enter the combined height and width of the
items you just measured. When you are done
entering in the values, click OK to return to the
workspace.

3. Next select Layout>Page Size. In Page Size
enter the height and width of the items you just
measured. When you are done entering in the
values, click OK to return to the workspace.
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4. The items’collective dimensions will now be
represented by a black box located within the
workspace. If this is not displayed, click
View>Show Page Size to view black box.

Once the total print area has been set, you must now determine the location
where each individual image is to be applied.

1. Measure the item that is closest to the upper
left hand corner of the print bed. Measure from
the left side of the print bed to the center point
where the image will be located (X axis).1 1/2” 
= 1.5”

2. Using the same item, measure from the top
of the print bed down to the bottom point of
the image (Y axis). The red dotted line
identifies the measurement taken for the
bottom of the logo. 2 1/2” = 2.5”

Upper Left-hand Corner

Upper Left-hand
Corner

Upper Left-hand
Corner
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3. Steps 1 and 2 will give you the location in which to position the first image. Using
the rulers positioned around the FastARTISTTM workspace, place the image in
the desired location. You may also select the image in the workspace and type in
the desired location in the x/y boxes.

4. Repeat steps 1, 2 and 3 for the remaining items in the print bed. For your
convenience, we suggest measuring the items starting in the upper left hand
corner and moving left to right from top to bottom.

Setting up FastRIPTM

Once an image is printed to FastRIPTM, it will
open and proceed to spool the print job.

1. Double click on the file in the Queue
window.

2. This will now bring up the Job Ticket
Properties window. Under the General
tab select the Max Ink tab. Check the
Overwrite Print Mode Max Ink Data box
and change the Max Ink Level from 400
to 300, click OK.

Positioning for Printing
1. Set the item in the upper left-hand corner

of the print bed without a shirt board
loaded in. Raise the bed and use the
height adjustment bar to make sure it is at
the proper height. (Consult Chapter 2 of
this manual for more details.) For odd
shaped items, create a holder or fixture to
hold the items in place during printing. Print
using the standard Photo Print Mode
settings for white T-Shirts. Sample prints
may be necessary to determine the correct
Print Mode settings.

Upper Left-hand
Corner
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2. Once all of these setup instructions have been completed, right-click on the job
within FastRIPTM and select Print.

Fast T-JET™ Non-Textile Post-treatment
Fast T-JET™ Non-Textile Post-treatment is a protective coating used for
prints on non-textile surfaces. Use this product along with our other non-
textile treatments such as Fast T-JET™ Brand Non-Textile Pretreatment
to achieve a long life for your prints while waterproofing and preventing the
ink colors from fading due to UV exposure..

DIRECTIONS FOR USE:

Shake can before each use. Spray onto non-textile,
printed surfaces after drying has been completed.
Apply a thin coat, 4 to 8 inches from surface. Use a
swift motion to prevent over spray and unwanted
buildup. If build up occurs, use lacquer thinner to
reduce. A second coat may be applied after
approximately two minutes of dry time. Let surface
dry for 30 minutes to one hour. Let dry in a clean,
dust free area to prevent debris from sticking to the
surface. Clean valve after use. Turn can upside
down and spray a short burst until cleared. If a
nozzle is clogged or sprays inconsistently, check for coating in the opening. Scrape off
with soft object and twist valve one half turn. Allow 24 hours cure time prior to placing
coated graphics into service.
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Printing Golf Balls

Before printing golf balls you must first install special Print Modes designed specifically
for printing small images found on items such as golf balls.

1. Locate the FastJet2.pmz file within the Non-Textile Print Modes Folder on the Non-
Textile Printing CD or download from the following web address:
http://screenprinters.net/non-textile_home.php?

a. If you are downloading the Print Modes, save the zip file onto your hard drive
in a location/folder you will be able to easily find again. After downloading the
file, WinZipTM should ask if you wish to unzip the file contents. Click Ok. You
will then be notified of the number of files extracted.

b. Locate the newly extracted file called FastJet2.pmz (it will be in the same
location/folder where you saved the downloaded zip file) and drag it onto your
desktop.

2. Open FastRIPTM. Select Printers > Manage Print Modes.

3. Use the drop down menu and select Fast T-
Jet 2.

4. A list of print modes will be displayed and the
icons located at the top of the window will
become available.



Chapter 7 - Printing Other Items

87

5. Select Import Print Mode Package identified below.

6. Locate the CD folder Non-Textile Print Modes to access the FastJet2.pmz file (or on
the desktop if downloaded) and click Open.

7. A list of four print modes should appear below, Select All and then select Import.

8. There will be a new folder called Non-Textile Print Modes in the Print Mode Manager
window. Expand the folder’s contents by clicking on the black triangle to the left of
the folder.
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9. Place a check in the box to the left of the folder and for all the listed print modes.

10.Select Import Selected Print Modes to Control Panel . This is represented by an
icon of a blue clip board with a red check on it.

11.Close the window and you now have Non-Textile 1440 print modes for golf balls.

Pre-Treating the Golf Balls

For printing golf balls it is recommended you use the
optional Golf Ball Holder, Fast T-Jet™ Non-Textile
Pretreatment and Fast T-JET™ Brand Non-Textile Post-
Treatment. Fast T-Jet™ Non-Textile Primer is not
necessary for golf ball printing. Ink adheres well enough to
the ball’s surface with just a pretreatment.

1. Load the golf balls into the holder and place the guard
on top of the balls. The guard will protect any areas not
being Pre-treated from overspray.
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2. Dip a fine bristle brush in the pretreatment, wiping off
any excess on the side of the bottle. Gently brush
pretreatment over the exposed golf ball surface
making sure there are no uneven areas.

3. Allow pretreatment to thoroughly dry before printing on it. Dry time will vary but it can
take up to one hour or more. To speed up the drying process use a hair dryer, heat
lamp, or heat gun set on a low temperature setting.

Loading Golf Ball Template (FastARTISTTM Only)

1. Go to File>Open and double click on Golf Ball Holder Template to open template.

2. Import the images or text you wish to print and place them inside of the lines.

3. Choose one of the following print modes:

Non-Textile Photo 1440 Standard

Non-Textile Photo 1440 Standard HS

Non-Textile Cartoon 1440 Standard

Non-Textile Cartoon 1440 Standard HS

4. Print to FastRIPTM.
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Golf Ball Holder Placement

Position the Golf Ball Holder in the top-left corner of the
print bed without a shirt board loaded in. Holder will be
positioned from left to right within the print bed. Raise the
bed and use the height adjustment bar to make sure it is at
the right height (Consult Chapter 2 of this manual for more
details.)

Once all the previous setup instructions have been
completed, right-click on the job within FastRIPTM and select Print.

Finish with Fast T-JET™ Brand Non-Textile Post-Treatment

DIRECTIONS FOR USE:

Shake can before each use. Spray onto non-textile, printed surfaces after drying has
been completed. Apply a thin coat, 4 to 8 inches from surface. Use a swift motion to
prevent over spray and unwanted buildup. If build up occurs, use lacquer thinner to
reduce. A second coat may be applied after approximately two minutes of dry time. Let
surface dry for 30 minutes to one hour. Let dry in a clean, dust free area to prevent
debris from sticking to the surface.

Non-Textile Printing Tips

 When brushing on any of the treatments, make sure it is placed on smoothly and
evenly in thin layers.

 Having two brushes can make the job easier. Use one for the Non-Textile Primer
Treatment and one for the Non-Textile Pretreatment.

 Cleaning the brushes when done with hot water and letting them dry will prevent
them from drying out and ruining the bristles.

 When printing on Non-Textile items, use a piece of film that covers the whole
item and print on the film to see if it aligns and prints correctly.

 The Print Bed area is 13” X 18” on a T-JET Standard and 13” x 22” on a T-Jet
Jumbo 2TM. To maximize production you can line up multiple items next to each
other and print more then one at a time.

 If you have a heat press under which you can place the items, do so without
allowing the element to make contact with them. This will dry the items faster.

Upper Left-hand
Corner


